企业绩效管理网

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 536|回复: 9

Can't open an Excel file on one of the Citrix Server ...

[复制链接]

77

主题

392

帖子

558

积分

高级会员

Rank: 4

积分
558
QQ
发表于 2014-3-17 12:04:03 | 显示全部楼层 |阅读模式
One of my users is having issues where sometimes she can open an Excel document from TM1 and sometimes she cannot. The issue is not consistent. I have noticed that she has the problem when she is connected to the Citrix server A, but she does not have the problem when connected to server B.

When's she's connected to server A she can see the name of the file but instead of having an Excel icon it has a Turbo Integrator icon. She can't double click on it, if she does then it goes back to the Application folder in which the file exists.

When she's connected to server B the icon is normal and she can open it up without any problem.

I can't explain it. Is there some setting in the .ini file or something that might indicate whether a user is allowed to use Excel files? I can't think what might be different between the two Citrix servers that might be causing the problem.

EDIT: This could be co-incidence, but if I give her admin access or she logs in as me then she can see the file. Though I'm not 100% certain whether I tried those options on server A or server B, so it may be unrelated. I've given her admin access to the Application folder.

Martin
回复

使用道具 举报

85

主题

433

帖子

616

积分

高级会员

Rank: 4

积分
616
QQ
发表于 2014-3-17 13:29:23 | 显示全部楼层
Martin Ryan wrote:One of my users is having issues where sometimes she can open an Excel document from TM1 and sometimes she cannot.  The issue is not consistent.  I have noticed that she has the problem when she is connected to the Citrix server A, but she does not have the problem when connected to server B.

When's she's connected to server A she can see the name of the file but instead of having an Excel icon it has a Turbo Integrator icon.  She can't double click on it, if she does then it goes back to the Application folder in which the file exists.

When she's connected to server B the icon is normal and she can open it up without any problem.

I can't explain it.  Is there some setting in the .ini file or something that might indicate whether a user is allowed to use Excel files?  I can't think what might be different between the two Citrix servers that might be causing the problem.

EDIT:  This could be co-incidence, but if I give her admin access or she logs in as me then she can see the file.  Though I'm not 100% certain whether I tried those options on server A or server B, so it may be unrelated.  I've given her admin access to the Application folder.

Sounds more like the file type assignment to Excel is broken for her login. Under her login on the problem server, try right clicking on the workbook file (you can do this in either Windows Explorer or through File -> Open) and select Properties. On the General tab it should show "Opens With Microsoft Excel". If it doesn't, and it wouldn't surprise me if it doesn't, then click the [Change] button and re-assign .xls files to Excel.
回复 支持 反对

使用道具 举报

64

主题

404

帖子

556

积分

高级会员

Rank: 4

积分
556
QQ
发表于 2014-3-17 13:31:27 | 显示全部楼层
If it is an option, we have noticed that deleting the roaming profile clears up most of the strange issues that seem to be related to a specific user. Not the best solution, but it has worked when nothing else would.
回复 支持 反对

使用道具 举报

77

主题

412

帖子

594

积分

高级会员

Rank: 4

积分
594
QQ
发表于 2014-3-17 13:39:57 | 显示全部楼层
can she open a non-tm1 excel file on the server or does she log straight into perspectives? sounds like the excel config on the server aint quite right but if you can access no problem then maybe its to do with her profile

I've watched some of my sheets behave very oddly when on citrix, very hard to work out what is going on

the .ini file should be global for that citrix box so you should be using the same .ini as her


random thoughts:

on 9.5 there is the capabilities cube but don't think it defines if you can access apps or not would have to check

one thing I've noticed is that the BLOB file that TM1 uses to link to an excel sheet doesn't always function well - have you tried saving the sheet back up to the server? may fix the blob (i don't think this is the issue but the BLOB don't work quite as well as they should)
回复 支持 反对

使用道具 举报

81

主题

424

帖子

616

积分

高级会员

Rank: 4

积分
616
QQ
发表于 2014-3-17 13:56:45 | 显示全部楼层
Thanks for the ideas guys.  I'll try them out when I can next get on her machine.  I've given her a workaround so she's not so interested any more.  Will let you know what turns out to be the solution.
回复 支持 反对

使用道具 举报

66

主题

363

帖子

518

积分

高级会员

Rank: 4

积分
518
QQ
发表于 2014-3-17 14:53:52 | 显示全部楼层
what was your workaround?
回复 支持 反对

使用道具 举报

74

主题

428

帖子

599

积分

高级会员

Rank: 4

积分
599
QQ
发表于 2014-3-17 14:54:59 | 显示全部楼层
This seems to be a bug with some versions of TM1. Some of my users experience the same problem. And the reason that only some of them are getting it seems to be connected to... how they click. If they expand their application folders by quick double-clicking, they are more likely to see an excel file with the TI icon (and then obviously, it won't open). Conversely, if they use the + sign to expand the application folder tree, they don't get this error.  Hope this helps.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复 支持 反对

使用道具 举报

83

主题

418

帖子

603

积分

高级会员

Rank: 4

积分
603
QQ
发表于 2014-3-17 14:55:56 | 显示全部楼层
dubs wrote:what was your workaround?

I logged on as an administrator and opened the file, then saved it on her C:.  Could just as easily have saved it somewhere on the network.
qml wrote:This seems to be a bug with some versions of TM1. Some of my users experience the same problem. And the reason that only some of them are getting it seems to be connected to... how they click.

That's.... odd.  I'll investigate that next time.

Thanks for all the suggestions.

Martin
回复 支持 反对

使用道具 举报

77

主题

412

帖子

590

积分

高级会员

Rank: 4

积分
590
QQ
发表于 2014-3-17 15:05:42 | 显示全部楼层
We have had this happen before but we implemented a weekly reboot of our Citrix farm. Once a week on a Friday night we have a physical server reboot of all Citrix servers in the farm. NOTE in your farm there will be one server which defines the rest of the farm. Allow this one one to come up first before the others are restarted....usually 30mins is enough.

We also, every three months delete profiles to keep them as clean as possible. We're using REN printers to ensure printer choices are always picking up native ones installed on the users laptops, and also have a standard "Book1" template for all Citrix users which has the add-in included as well as all network drives the user has access too. This allows a profile deletion across the farm of user profiles without causing issues
回复 支持 反对

使用道具 举报

80

主题

402

帖子

587

积分

高级会员

Rank: 4

积分
587
QQ
发表于 2014-3-17 15:07:08 | 显示全部楼层
qml wrote:This seems to be a bug with some versions of TM1. Some of my users experience the same problem. And the reason that only some of them are getting it seems to be connected to... how they click. If they expand their application folders by quick double-clicking, they are more likely to see an excel file with the TI icon (and then obviously, it won't open). Conversely, if they use the + sign to expand the application folder tree, they don't get this error.  Hope this helps.

Knock me down with a feather.  When you suggested that I thought you might have forgotten your pills that day.  But that did indeed fix it.

I doubt I'm going going to get a Citrix farm restart as TM1's one of many apps running on it.  But I might have some luck with deleting roaming profiles.

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|手机版|小黑屋|企业绩效管理网 ( 京ICP备14007298号   

GMT+8, 2020-9-20 06:48 , Processed in 0.178532 second(s), 12 queries , Memcache On.

Powered by Discuz! X3.1 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表